WordPress: The server does not have ImageMagick or GD installed and/or enabled!

  • 09.11.2015
  • 6 185
  • 0
  • 03.04.2019
  • 1
  • 1
  • 0
WordPress: The server does not have ImageMagick or GD installed and/or enabled

Описание проблемы

После установки/переноса сайта на WordPress, с одного хостинга на другой, выскочила следующая ошибка:

The server does not have ImageMagick or GD installed and/or enabled! Any of these libraries are required for WordPress to be able to resize images. Please contact your server administrator to enable this before continuing.

Исправление ошибки

Решение простое - нужно установить расширения для работы PHP с изображениями - ImageMagick или GD. В примере ниже будет рассмотрена установка ImageMagick.

Обновляем список пакетов:

aptitude update

Выкачиваем необходимые обновления для них:

aptitude upgrade

Устанавливаем необходимое расширение:

aptitude install php5-imagick

После этого перезапускаем apache2, если он используется в качестве веб-сервера:

service apache2 restart

Или перезапускаем службу php5-fpm, если используется nginx:

service php5-fpm restart

Была ли эта статья Вам полезна?

Добавить комментарий

Ваш адрес email не будет опубликован.

Напоминаем Вам, что Ваше сообщение будет опубликовано только после проверки администратором сайта. Обычно это занимает 1-2 рабочих дня.