Исправляем ошибку: configure: error: no usable spandsp; please install spandsp3 devel package or equivalent

Исправляем ошибку: configure: error: no usable spandsp please install spandsp3 devel package or equivalent

Описание

При установке FreeSWITCH на сервер с Ubuntu столкнулся с ошибкой, которая не позволяла скомпилировать FreeSWITCH из исходников:

configure: error: no usable spandsp; please install spandsp3 devel package or equivalent

Как исправить

Для исправления ошибки делаем следующее:

cd /usr/src/
git clone https://github.com/freeswitch/spandsp.git
cd spandsp
./bootstrap.sh
./configure
make
make install

Если все сработало, то можно возвращаться к компиляции из исходных кодов FreeSWITCH.
Если после компиляции при запуске будет вылазить ошибка:

freeswitch: error while loading shared libraries: libspandsp.so.3: cannot open shared object file: No such file or directory

То можно попробовать выполнить следующую команду:

ldconfig
Была ли эта статья Вам полезна?

Добавить комментарий

Ваш адрес email не будет опубликован.

Напоминаем Вам, что Ваше сообщение будет опубликовано только после проверки администратором сайта. Обычно это занимает 1-2 рабочих дня.