Исправляем ошибку: checking for sofia-sip-ua >= 1.12.12... configure: error: no usable sofia-sip; please install sofia-sip-ua devel package or equivalent

Исправляем ошибку: checking for sofia-sip-ua  1.12.12... configure: error: no usable sofia-sip please install sofia-sip-ua devel package or equivalent

Описание

При установке FreeSWITCH на сервер с Ubuntu столкнулся с ошибкой, которая не позволяла скомпилировать FreeSWITCH из исходников:

checking for sofia-sip-ua >= 1.12.12... configure: error: no usable sofia-sip; please install sofia-sip-ua devel package or equivalent

Как исправить

Для исправления ошибки можно проделать следующее:


cd /usr/src/
git clone https://github.com/freeswitch/sofia-sip.git
cd sofia-sip
./bootstrap.sh
./configure
make
make install

Если все сработало, то можно возвращаться к компиляции из исходных кодов FreeSWITCH. Если не помогло, то в интернете встречал еще рекомендацию проделать следующее (после приведенных выше команд):

ldconfig
Была ли эта статья Вам полезна?

Добавить комментарий

Ваш адрес email не будет опубликован.

Напоминаем Вам, что Ваше сообщение будет опубликовано только после проверки администратором сайта. Обычно это занимает 1-2 рабочих дня.