Исправление ошибки "error: Package requirements (fontconfig) were not met:"

  • 08.08.2020
  • 143
  • 0
  • 09.08.2020
  • 1
  • 1
  • 0
Исправление ошибки error: Package requirements (fontconfig) were not met:

Описание и исправление ошибки

Довольно часто, совместно с исходными кодами, в комплекте идет скрипт предварительной конфигурации, под названием configure, который помимо прочего проверяет наличие необходимых библиотек. В случае, если данный скрипт выдал следующее сообщение:

error: Package requirements (fontconfig >= 2.4.1) were not met:

Для того, чтобы библиотеки fontconfig, необходимые для сборки появились в системе, нужно установить пакет под названием libfontconfig1-dev:

sudo apt install libfontconfig1-dev

И после этого, ошибка про отсутствие fontconfig должна исчезнуть.

Была ли эта статья Вам полезна?

Добавить комментарий

Ваш адрес email не будет опубликован.

Напоминаем Вам, что Ваше сообщение будет опубликовано только после проверки администратором сайта. Обычно это занимает 1-2 рабочих дня.